Circle Sandbox - USDC Flow - Minting and Burning
Incident Report for Circle
Resolved
This incident has been resolved.
Posted May 21, 2024 - 15:44 UTC
Investigating
The Flow testnet is currently experiencing a network outage affecting all testnet operations. Operations will be possible once the Flow testnet network has been restored.

https://status.onflow.org/
Posted May 20, 2024 - 21:52 UTC
This incident affected: Circle - Sandbox and 3rd Party Infrastructure & Systems.