Slow USDC-SOL transactions
Incident Report for Circle
Resolved
This incident has been resolved.
Posted May 01, 2021 - 00:39 UTC
Monitoring
Blocks are currently processing and actively catching up
Posted Apr 30, 2021 - 18:25 UTC
Investigating
We are currently investigating this issue.
Posted Apr 30, 2021 - 17:37 UTC
This incident affected: USDC (Minting, Redeeming).