Elevated payments processing failure rates
Incident Report for Circle
Resolved
This incident has been resolved.
Posted May 05, 2021 - 18:10 UTC
Investigating
We are currently investigating elevated failures rates on payments processed by one of our vendors.
Posted May 05, 2021 - 15:31 UTC
This incident affected: APIs (Payouts API).