Hedera USDC - Mainnet Unavailable
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Jan 23, 2023 - 20:44 UTC
Update
We are continuing to investigate this issue.
Posted Jan 23, 2023 - 20:43 UTC
Investigating
Due to the a Hedera blockchain emergency maintenance, USDC on Hedera is temporarily unavailable until Monday 01/23/2023. We will provide frequent updates. Thank you for your understanding and apologies for the inconvenience.
Posted Jan 20, 2023 - 19:37 UTC
This incident affected: USDC (USDC - HBAR - Minting, USDC - HBAR - Redeeming).