Payments API is experiencing performance degradation
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Jun 17, 2022 - 20:57 UTC
Investigating
The Payments API is experiencing performance degradation, we are working to resolve this as soon as possible.
Posted Jun 17, 2022 - 18:32 UTC