Minting and Redeeming USDC issue
Incident Report for Circle
Resolved
This issue has been resolved and Silvergate Exchange Network (SEN) transactions are operating normally. Previously stuck transactions were processed successfully.
Posted Feb 23, 2021 - 05:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 23, 2021 - 02:53 UTC
Investigating
We are investigating issues minting and redeeming USDC to and from Silvergate Exchange Network (SEN) accounts
Posted Feb 23, 2021 - 02:39 UTC
This incident affected: USDC (Minting, Redeeming).