USDC SOL Network Degradation
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Oct 02, 2022 - 00:11 UTC
Investigating
Due to Solana network instability, we have degraded performance on Solana. This affects USDC minting and redeeming.

For additional context regarding the Solana network degradation, please visit the following Solana status page https://status.solana.com/incidents/kxsv0xcz9dn3
Posted Sep 30, 2022 - 22:29 UTC
This incident affected: USDC (USDC - SOL - Minting, USDC - SOL - Redeeming).