Authentication Issues
Incident Report for Circle
Resolved
We have identified and resolved the issue.
Posted Sep 21, 2022 - 00:27 UTC
Identified
Circle has identified the cause of the issue that has been impacting Circle Login. The team are applying the corrective action and we will provide further updates once they become available.
Posted Sep 20, 2022 - 23:03 UTC
Investigating
Circle has been notified that some customers are experiencing intermittent issues with login to their Circle Account. Circle is investigating and will update the status site shortly.
Posted Sep 20, 2022 - 22:51 UTC
This incident affected: Circle - Website.