USDC and CCTP on Noble - Delayed Transactions

Incident Report for Circle

Resolved

This incident has been resolved
Posted Mar 18, 2025 - 20:14 UTC

Update

USDC minting and burning on Noble has been restored. We are continuing to investigate issues affecting CCTP on Noble
Posted Mar 18, 2025 - 13:42 UTC

Update

We are continuing to investigate this issue.
Posted Mar 18, 2025 - 02:50 UTC

Update

We are continuing to investigate this issue.
Posted Mar 18, 2025 - 02:37 UTC

Update

USDC minting an burning may also experience delays. We are continuing to investigate.
Posted Mar 18, 2025 - 02:20 UTC

Investigating

CCTP transactions on Noble are delayed due to network issues. We are currently investigating the cause.
Posted Mar 18, 2025 - 00:41 UTC
This incident affected: Circle - Cross-Chain Transfer Protocol (NOBLE - Cross-Chain Minting and Burning).