Delayed Circle Payout on Polygon
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Jun 24, 2024 - 04:56 UTC
Investigating
Circle Payout on Polygon network is experiencing delays due to technical issues, we are investigating the issue right now.
Posted Jun 24, 2024 - 01:34 UTC
This incident affected: APIs (Payouts API).