We are continuing to monitor for any further issues.
Posted Apr 14, 2026 - 15:39 UTC
Monitoring
The issue has been resolved. We will continue to monitor performance to ensure ongoing stability.
Posted Apr 14, 2026 - 08:56 UTC
Investigating
Solana Devnet is currently stalled at block 455,406,479. It is confirmed as a network-wide issue and we are investigating the situation.
Posted Apr 14, 2026 - 04:53 UTC
This incident affected: Circle Testnet Faucet (Public Faucet – SOL Devnet, InConsole Faucet – SOL Devnet) and Circle Gateway (Circle Gateway: Solana - Devnet).