USDC on Solana delayed mints, burns, and sends

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Mar 15, 2025 - 20:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2025 - 19:59 UTC

Update

We are continuing to investigate this issue.
Posted Mar 15, 2025 - 19:48 UTC

Update

We are continuing to investigate this issue.
Posted Mar 15, 2025 - 18:46 UTC

Investigating

USDC mints, burns and sends on Solana are delayed due to network congestions. We are working on updates to improve the speed.
Posted Mar 15, 2025 - 18:45 UTC
This incident affected: USDC (USDC - SOL - Minting, USDC - SOL - Redeeming).