Hedera USDC - Hedera Mainnet Unavailable
Incident Report for Circle
Resolved
The issue was solved, and the Hedera mint, redeem, and send processes on Circle are currently reenabled.
Posted Mar 13, 2023 - 16:16 UTC
Update
We are continuing to investigate this issue.
Posted Mar 10, 2023 - 02:09 UTC
Investigating
Due to an issue affecting the Hedera mainnet network, all Hedera mint, redeem, and sends on Circle are currently disabled. We will resume all Hedera mint, redeem, and sends on Circle once Hedera nodes are operational.

https://status.hedera.com/incidents/j27rmgv4plcl
Posted Mar 09, 2023 - 20:49 UTC
This incident affected: USDC (USDC - HBAR - Minting, USDC - HBAR - Redeeming).