[ARB-SEPOLIA] services impacted due to slow response

Incident Report for Circle

Resolved

We are seeing all stuck txs have been updated correctly.
Posted Oct 13, 2025 - 10:31 UTC

Identified

We are seeing unexpected network issues impacting Circle Web3 Services on ARB-SEPOLIA, causing transaction delays or degraded performance.
Posted Oct 13, 2025 - 09:39 UTC
This incident affected: Web3 Services Console (W3S Console - Programmable Wallets).