CCTP & USDC on Sei Delayed mints and burns

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 18:07 UTC

Investigating

USDC mints and burns on SEI are delayed due to network issues. CCTP transactions are also impacted. We are currently investigating the cause.
Posted Oct 23, 2025 - 16:08 UTC
This incident affected: Circle Cross-Chain Transfer Protocol (SEI - Cross-Chain Minting and Burning) and USDC (USDC - SEI - Minting, USDC - SEI - Redeeming).