We are continuing to work with the third party to resolve this issue.
Posted Aug 31, 2025 - 14:05 UTC
Identified
We’ve noticed a delay in travel rule services related to third-party integration, which may impact Circle customers in Singapore. We are actively collaborating with the third party to resolve this issue.
Posted Aug 31, 2025 - 03:18 UTC
This incident affected: Web3 Services APIs (Travel Rule API) and 3rd Party Infrastructure & Systems.