USDC on Base Delayed Mint/Burns/Sends

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 13:44 UTC

Investigating

USDC mints, burns and sends on Base are delayed due to network issues.
Posted Apr 11, 2025 - 06:52 UTC
This incident affected: USDC (USDC - BASE - Minting, USDC - BASE - Redeeming).