USDC Noble - Delayed mints and burns

Incident Report for Circle

Resolved

This incident is resolved
Posted Feb 27, 2025 - 21:03 UTC

Monitoring

The Noble mainnet has resumed operations. We are continuing to monitor for any residual effects.
Posted Feb 27, 2025 - 19:37 UTC

Update

We are continuing to investigate this issue.
Posted Feb 27, 2025 - 18:11 UTC

Investigating

USDC mints and burns on Noble are delayed due to network issues. We are currently investigating the cause.
Posted Feb 27, 2025 - 18:01 UTC
This incident affected: Circle - Cross-Chain Transfer Protocol (NOBLE - Cross-Chain Minting and Burning) and USDC (USDC - NOBLE - Minting, USDC - NOBLE - Redeeming).