Sui testnet degredation

Incident Report for Circle

Resolved

This incident has been resolved
Posted Apr 29, 2025 - 18:25 UTC

Update

We are continuing to investigate this issue.
Posted Apr 29, 2025 - 17:34 UTC

Investigating

We're investigating into degradation related to Sui testnet.
Posted Apr 29, 2025 - 17:23 UTC
This incident affected: Circle Mint APIs (Circle Mint - Sandbox APIs), Circle Mint (Circle Mint - Sandbox), and Circle - Testnet Faucet (Public Faucet – SUI Testnet).