USDC SOL Network Issues
Incident Report for Circle
Resolved
This incident has been resolved.
Posted May 10, 2022 - 12:41 UTC
Investigating
We have temporarily disabled USDC-SOL mints and withdrawals due to the SOL network experiencing networking performance degradation. Pending transactions may be delayed and will be processed as the network improves.
Posted May 09, 2022 - 20:28 UTC
This incident affected: USDC (Minting, Redeeming).