Delayed mint/burn on STMT due to chain outage

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 19:39 UTC

Monitoring

USDC mints and burns on STMT are delayed due to network issues. We are currently investigating the cause.
Posted Sep 11, 2026 - 02:09 UTC