usdc.com - Performance Degradation

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Sep 19, 2024 - 07:45 UTC

Investigating

The USDC website (https://www.usdc.com) is available intermittently. We are working with 3rd party service providers to resolve the issue and will provide further information as it becomes available.
Posted Sep 19, 2024 - 03:21 UTC
This incident affected: Circle Websites (usdc.com).