CELO Network Issues

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Sep 14, 2025 - 10:47 UTC

Identified

USDC mints and burns on Celo are delayed due to network issues. We are currently investigating the cause.
Posted Sep 14, 2025 - 06:43 UTC
This incident affected: USDC (USDC - CELO - Minting, USDC - CELO - Redeeming).