Near Testnet Issues

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 14:56 UTC

Investigating

Due to internal issues, faucet and other USDCNEAR operations are unavailable. We are investigating and will restore service as soon as possible.
Posted Dec 02, 2025 - 15:41 UTC
This incident affected: Circle Mint (Circle Mint - Sandbox) and Circle Testnet Faucet (Public Faucet – NEAR Testnet).