USDC Access partially unavailable

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 23:45 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 02:31 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 02:05 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 21, 2025 - 02:03 UTC

Identified

We have identified one of the 3rd party provide that supports USDC Access is still having an outage.
Posted Oct 21, 2025 - 00:04 UTC
This incident affected: USDC Access (USDC Access Widget, USDC Access API) and 3rd Party Infrastructure & Systems.