Circle Mint operations on Cronos have been restored, and we are monitoring the results.
Posted Sep 02, 2026 - 02:53 UTC
Monitoring
Cross-Chain Transfer Protocol (CCTP) operations on Cronos have been restored, and we are monitoring the results. Circle Mint operations on Cronos remain unavailable.
Posted Sep 01, 2026 - 21:42 UTC
Identified
We are working with the Cronos team to implement a fix and restore service.
Posted Aug 31, 2026 - 06:23 UTC
Investigating
The Cronos Mainnet is currently experiencing a network outage affecting all Cronos operations. Operations will be possible once the Cronos network has been restored.
Posted Aug 30, 2026 - 14:58 UTC
This incident affected: EURC (EURC - CRONOS - Redeeming, EURC - CRONOS - Minting), Circle Cross-Chain Transfer Protocol (CRONOS - Cross-Chain Minting and Burning), 3rd Party Infrastructure & Systems, and USDC (USDC - CRONOS - Redeeming, USDC - CRONOS - Minting).