USDC SUI - Delayed minting and burning
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 22:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 21, 2024 - 12:19 UTC
Investigating
USDC mints and burns on Sui are experiencing technical difficulties and temporary delays due to an issue with the Sui network. We are currently working to resolve the issue.

https://status.sui.io/incidents/f2yz7qzwcc94
Posted Nov 21, 2024 - 12:10 UTC
This incident affected: 3rd Party Infrastructure & Systems and USDC (USDC - SUI - Minting, USDC - SUI - Redeeming).