SEI block processing issue

Incident Report for Circle

Resolved

Issue has been resolved
Posted May 19, 2026 - 22:41 UTC

Investigating

We are seeing unexpected network issues impacting SEI mainnet, causing delay for CCTP attestation.
Posted May 19, 2026 - 22:13 UTC
This incident affected: Circle Cross-Chain Transfer Protocol (SEI - Cross-Chain Minting and Burning).