USDC mints and burns on Sei are experiencing technical difficulties and temporary delays. We are currently investigating the cause and working to resolve the issue.
Posted Nov 05, 2025 - 02:02 UTC
Investigating
USDC mints and burns on Sei are experiencing technical difficulties and temporary delays. We are currently investigating the cause and working to resolve the issue.
Posted Nov 05, 2025 - 01:11 UTC
This incident affected: Circle Cross-Chain Transfer Protocol (SEI - Cross-Chain Minting and Burning) and USDC (USDC - SEI - Minting, USDC - SEI - Redeeming).