Delayed USDC mints and burns on XLM

Incident Report for Circle

Resolved

This incident has been resolved.
Posted 4 months ago. Mar 04, 2025 - 03:56 UTC

Investigating

USDC mints and burns on XLM are experiencing technical difficulties and temporary delays. We are currently investigating the cause and working to resolve the issue.
Posted 4 months ago. Mar 04, 2025 - 01:07 UTC
This incident affected: EURC (EURC - XLM - Minting, EURC - XLM - Redeeming).