Testnet Faucet - ETH Sepolia unavailable

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 11:48 UTC

Investigating

We are currently investigating this issue.
Posted Mar 25, 2025 - 11:02 UTC
This incident affected: 3rd Party Infrastructure & Systems.