Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2025 - 16:30 UTC
Scheduled
Due to a scheduled upgrade on the Noble mainnet, all USDC-Noble mints, redeeming, and sending operations on Circle will be temporarily paused. We appreciate your patience and will provide updates as soon as the upgrade is complete.
Posted Mar 04, 2025 - 21:35 UTC
This scheduled maintenance affected: Circle - Cross-Chain Transfer Protocol (NOBLE - Cross-Chain Minting and Burning) and USDC (USDC - NOBLE - Minting, USDC - NOBLE - Redeeming).