Slow Payment Processing

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 21:07 UTC

Investigating

We are currently investigating slow payment processing
Posted Mar 26, 2025 - 20:45 UTC
This incident affected: Circle Mint (Circle Mint - Payments & Transfers).