USDC on Noble Delayed mints and burns

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 14:08 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2025 - 13:57 UTC

Update

We are continuing to work on a fix for this issue.
Posted Feb 17, 2025 - 13:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 17, 2025 - 13:30 UTC

Investigating

USDC mints and burns on Noble are experiencing technical difficulties and temporary delays. We are currently investigating the cause and working to resolve the issue.
Posted Feb 17, 2025 - 13:12 UTC
This incident affected: USDC (USDC - NOBLE - Minting, USDC - NOBLE - Redeeming).