A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2024 - 17:34 UTC
Identified
A planned Noble maintenance requires pausing all Noble mint, redeem, and sends on Circle. This does not interrupt the transferability of the USDC on Noble token on non-Circle platforms.
Posted Nov 13, 2024 - 14:18 UTC
This incident affected: Circle - Cross-Chain Transfer Protocol (NOBLE - Cross-Chain Minting and Burning), 3rd Party Infrastructure & Systems, and USDC (USDC - NOBLE - Minting, USDC - NOBLE - Redeeming).