We have implemented a workaround to redirect https://usdc.com to https://circle.com/usdc. Some deep links to usdc.com may be temporarily available until the root cause can be fully addressed.
No USDC minting, redeeming, or API functionality is affected.
Posted Apr 14, 2026 - 16:26 UTC
Identified
The https://www.usdc.com/ website is down and returning 500 errors due to a third party provider. We are working closely with the provider to restore service as quickly as possible.
No USDC minting, redeeming, or API functionality is affected.
Posted Apr 14, 2026 - 15:41 UTC
Update
We are continuing to investigate this issue.
Posted Apr 14, 2026 - 15:39 UTC
Investigating
We are currently investigating reports of 5xx errors affecting the https://www.usdc.com/ website.
No USDC minting, redeeming, or API functionality is affected.
Posted Apr 14, 2026 - 15:04 UTC
This incident affected: Circle Websites (usdc.com).