Delays in Optimism (OP) Transaction Processing on Circle Mint

Incident Report for Circle

Resolved

The issue has been resolved.
Posted Apr 30, 2026 - 02:25 UTC

Monitoring

The issue has been resolved. We will continue to monitor performance to ensure ongoing stability.
Posted Apr 29, 2026 - 06:56 UTC

Update

Circle Mint is currently experiencing delay with processing transactions on OP. Our team is aware and actively working to restore service.
Posted Apr 29, 2026 - 05:45 UTC

Investigating

Circle Mint is currently experiencing delay with processing transactions on OP. Our team is aware and actively working to restore service.
Posted Apr 29, 2026 - 05:43 UTC