Circle Sandbox - USDC and CCTP on Noble testnet Delayed Transactions

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 13:48 UTC

Investigating

CCTP and USDC mints and burns on Noble testnet are delayed due to network issues. We are currently investigating the cause.
Posted Oct 16, 2025 - 13:41 UTC
This incident affected: Circle Mint (Circle Mint - Sandbox), Circle Testnet Faucet (Public Faucet – NOBLE Testnet), and 3rd Party Infrastructure & Systems.