USDC on Aptos Sandbox and Aptos Testnet Faucet Unavailable

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 15:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 28, 2025 - 12:25 UTC

Update

USDC - APTOS Minting and Redeeming have been restored. We are continuing to investigate issues affecting APTOS Testnet Faucet
Posted Mar 28, 2025 - 02:49 UTC

Update

We are continuing to investigate this issue.
Posted Mar 28, 2025 - 02:45 UTC

Investigating

We are currently investigating this issue.
Posted Mar 27, 2025 - 16:49 UTC
This incident affected: Circle - Testnet Faucet (Public Faucet – APTOS Testnet).