Matic Amoy Network Issue

Incident Report for Circle

Resolved

This incident has been resolved.
Posted May 08, 2026 - 01:26 UTC

Investigating

Investigating - The Matic Amoy is currently experiencing a network outage affecting all Matic Amoy operations. Operations will be possible once the Matic Amoy network has been restored.
Posted May 07, 2026 - 21:41 UTC
This incident affected: Circle Testnet Faucet (Public Faucet – MATIC Amoy, InConsole Faucet – MATIC Amoy) and Web3 Services APIs (MW - MATIC - AMOY - Balance APIs, PW - Dev-Controlled Wallets - MATIC - AMOY - Balance APIs, PW - Dev-Controlled Wallets - MATIC - AMOY - Transaction Creation/Estimation APIs).