USDC on Hedera Delayed mints and burns (network issues)
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 03:15 UTC
Investigating
USDC mints and burns on Hedera are experiencing technical difficulties and temporary delays. We are currently investigating the cause and working to resolve the issue.
Posted Apr 24, 2024 - 21:55 UTC
This incident affected: Circle - Sandbox, 3rd Party Infrastructure & Systems and USDC (USDC - HBAR - Minting, USDC - HBAR - Redeeming).