Delayed Mints for Deposits through Customers Bank
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Jul 19, 2024 - 20:26 UTC
Investigating
We are experiencing delayed mints for deposits sent to the Customers Bank wire account. Other banks and CBIT are not affected.
Posted Jul 19, 2024 - 18:50 UTC
This incident affected: APIs (Core Functionality).