The Avalanche mainnet is currently experiencing network degradation that affects all AVAX operations.
Incident Report for Circle
Resolved
This incident has been resolved.
Posted Feb 23, 2024 - 17:37 UTC
Update
We are continuing to investigate this issue.
Posted Feb 23, 2024 - 14:27 UTC
Investigating
We are currently investigating this issue.
Posted Feb 23, 2024 - 12:01 UTC
This incident affected: Circle - Cross-Chain Transfer Protocol (AVAX - Cross-Chain Minting and Burning), USDC (USDC - AVAX - Minting, USDC - AVAX - Redeeming), and 3rd Party Infrastructure & Systems.