Delayed transactions for Programmable Wallets on Base

Incident Report for Circle

Resolved

This incident has been resolved.
Posted May 08, 2025 - 07:39 UTC

Update

We are continuing to investigate this issue. Delayed transactions for USDC and EURC on Base are fixed.
Posted May 06, 2025 - 13:35 UTC

Update

We are continuing to investigate this issue.
Posted May 06, 2025 - 11:57 UTC

Investigating

USDC, EURC and Programmable Wallets transactions on Base are experiencing technical difficulties and temporary delays. We are currently investigating the cause and working to resolve the issue.
Posted May 06, 2025 - 09:42 UTC
This incident affected: EURC (EURC - BASE - Minting, EURC - BASE - Redeeming), USDC (USDC - BASE - Minting, USDC - BASE - Redeeming), and Web3 Services APIs (PW - Dev-Controlled Wallets - BASE - Transactions Creation/Estimation APIs).