Celo Sandbox Delays

Incident Report for Circle

Resolved

The issues have been resolved
Posted Oct 09, 2024 - 20:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 04, 2024 - 23:43 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 02, 2024 - 23:02 UTC

Update

We are experiencing performance degradation with outbound transfer for USDC Celo on Circle Sandbox. We are currently investigating the cause and working to resolve the issue.
Posted Oct 02, 2024 - 23:02 UTC

Identified

Work is underway to correct the issue.
Posted Oct 02, 2024 - 21:35 UTC