Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 30, 2025 - 00:00 UTC
Scheduled
We will be undergoing scheduled infrastructure maintenance starting at 00:00 UTC on Sunday 3/30/2025, 00:00 UTC to 00:30 UTC. We expect the maintenance window to last approximately 30 minutes. During this time, the following services and operations may be temporarily unavailable or experience degraded performance.
Circle Mint - Payments and Transfers APIs - Core Functionality USDC - Minting and Redeeming EURC - Minting and Redeeming
Once the maintenance is complete, the status page will be updated. We apologize for any inconvenience this may cause and appreciate your understanding as we work to improve our services.
Posted Mar 14, 2025 - 19:58 UTC
This scheduled maintenance affected: USDC (Minting, Redeeming), EURC (Minting, Redeeming), Circle Mint APIs (Circle Mint - Core Functionality API), and Circle Mint (Circle Mint - Payments & Transfers).