USDC on POLYGON Delayed mints and burns (network issues)

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Jan 12, 2026 - 17:42 UTC

Update

This incident also impacts Circle Gateway and Web3 services on POLYGON
Posted Jan 12, 2026 - 17:12 UTC

Investigating

USDC mints and burns, and Web3 services on POLYGON are delayed due to network issues. This also impacts CCTP fast burn transactions on POLYGON which will be degraded to standard transfers; fees for fast transfers will be waived. POLYGON is currently seeing a temporary network delay in block finality. Their team is actively investigating the cause and coordinating to restore full functionality. https://status.polygon.technology/incidents/zn9nysdpd7dz
Posted Jan 12, 2026 - 16:37 UTC
This incident affected: 3rd Party Infrastructure & Systems, Circle Cross-Chain Transfer Protocol (POLY - Cross-Chain Minting and Burning), and USDC (USDC - POLY - Minting, USDC - POLY - Redeeming).