Testnet Faucet - USDC on Celo unavailable

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 17:01 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 14, 2025 - 12:42 UTC

Identified

We have identified that the incident was caused by the Celo Testnet, we are awaiting the blockchain to resume processing blocks.
Posted Feb 27, 2025 - 18:01 UTC

Investigating

We are aware of USDC on Celo Testnet Faucet’s downtime and are currently investigating to resolve this issue.
Posted Feb 27, 2025 - 17:53 UTC
This incident affected: 3rd Party Infrastructure & Systems.