USDC on Base delayed mints and burns

Incident Report for Circle

Resolved

This incident has been resolved.
Posted May 28, 2025 - 18:15 UTC

Investigating

USDC mints, burns and sends on Base are delayed due to network issues.
https://status.base.org/#
Posted May 28, 2025 - 15:22 UTC
This incident affected: USDC (USDC - BASE - Minting, USDC - BASE - Redeeming) and 3rd Party Infrastructure & Systems.