CCTP & USDC on Plume Delayed mints and burns

Incident Report for Circle

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 23:31 UTC

Investigating

CCTP & USDC mints and burns on Plume are delayed while we upgrade our nodes.
https://docs.plume.org/plume/more/changelog
Posted Dec 03, 2025 - 22:07 UTC
This incident affected: Circle Cross-Chain Transfer Protocol (PLUME - Cross-Chain Minting and Burning) and USDC (USDC - PLUME - Minting, USDC - PLUME - Redeeming).